Dreamweaver  Portfolio Template Tutorial

Make sure you have a Dreamweaver folder created
in your Documents folder
Next Open Dreamweaver
Click on top menus Site > New Site

Label Site Name: lastname+first initial+dmportfolio
Click the folder on Local Site folder
Choose Documents > Dreamweaver
Click Save

There is now a folder upper right of screen under
Files tab for your website

Click Starter Templates
Click Basic  Simple grid

Dreamweaver shows a split view of Design and
Code for the template you will alter for the portfolio

From top menus select Window > Toolbars
Make sure a check box appears by each by
selecting any unchecked items: Document,
Standard, Common
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From top menus select Window > Properties
Properties menu should open at bottom of page, if opens separate then move and attach to the bottom
below the code view

At the top left of screen, below the simpleGrid.css
Click the double boxes with an arrow to Save All

Name the untitled html file as index (leave the .html)
Click the arrow to expand the window
Choose Documents > Dreamweaver
Save

The index is what all homepages are called
The index.html file now appears on the tab in the
upper left of the page

The Files tab in the upper right now has the
following: css, images, and your index.html
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The template has 8 thumbnail areas to display
portfolio work (2 row sections of 4 boxes in a row
when viewed in a desktop browser). You are going
to add 2 additional 4 box row areas, and can also
add another row for up to 4 extra credit projects if
you like

In Code view highlight lines 50 through 71 of the
source code to select it
Hold Command C to copy this code

In Code view locate the the second section
<div class=”gallery”> (begins with line 50 of the code)

Click right after the </div> tag on line 71

Hit Return (Enter) on keyboard to space down to the
beginning of line 72 of the code

Command V to paste
The copied code will paste from line 72 to line 93
This gives you an additional 4 row line of boxes for
portfolio items

You are going to repeat this process to add one
more row of 4 boxes
In Code view, Click to the right of the </div> tag on
line 93 and hit Return on the keyboard to space
down a line

Command V to paste
The copied code will paste from line 94 to line 115
This gives you another additional 4 row line of boxes
for portfolio items, and ends at Footer Section

Click the double boxes in the upper left to Save All
You now have 16 thumbnail box areas where you
will link to display your project work from the
semester.
*If you want to add one more row to display some of
the extra credit work you have done this year then
you will repeat this process to add an additional row
of 4 boxes. MAKE SURE YOU PLAN TO SHOW 4
ITEMS (OR MULTIPLES OF 4 LIKE 8, 12, ETC IF
YOU ARE GOING TO ADD MORE ROWS). DO
NOT ADD LESS THAN 4, SO TO KEEP UNITY.
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File > Quit Dreamweaver. You will come back to it
later
Open Finder
Click on Documents > Dreamweaver
ALL items that will be used to design your
website portfolio MUST be saved here
Notice the bkg and profile images in the images
folder. You will replace the bkg holders in the site
with images you make and profile with your photo.

Open Adobe Media Encoder

For consistency of appearance, you are going to
make all your Photoshop projects into still video clips

From Finder > Photoshop folder, drag your final
JPEG files of each of your Photoshop projects into
the Que area of Media Encoder

Click the drop down arrow to the far right of each file
and select H.264

Click the next drop down arrow to the right on each
file and select Match Source  Medium bitrate

Click on the blue underline Output file name of each
file
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Window will open when click the link
Select Documents > Dreamweaver > Images

Click the Green arrow in the upper right of screen
Each image will process as an MP4

Click Finder and all these files will now be in
Documents > Dreamweaver > images
DO NOT Quit Media Encoder

Open Animate
Open your previous Animate project FLA files
Hit (Shift+Command+4) and drag a box around
each of previous Animate project stage to take a
screenshot
Each screenshot will appear on your desktop

For each Animate project you will create an MP4
File > Export > Video

Do not change any setting, click Export

Go back to Media Encoder
Choose the same settings you chose for the images
H264, Medium Bitrate, click blue link for output file
Choose Documents > Dreamweaver > images
Click Green Arrow top right
Click Finder and all these files will now be in
Documents > Dreamweaver > images as MP4 files
Quit Media Encoder and quit Animate.
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Leave open the Finder window showing:
Documents > Dreamweaver > images
Command+N to open a second Finder window
Move the two windows so you can see them both
In the second Finder window go to:
Documents > Audition and hold Command and click
to select all of your MP3 files of your audio projects
Hold Command+C to copy

Click in the other Finder window inside the
Documents > Dreamweaver > images folder
Then hold Command+V to paste in the images
folder

Repeat this same copy and paste process from the
two Finder windows to copy over your Foley m4v file
and MP3 files from Garageband, and to also copy
over your MP4 videos from your Premiere folder
Close both Finder windows

Open Photoshop. New Document. Click Web.
Title the file with a name: Thumbnails
Change Size to 2000 Width x 1333 Height PIXELS
Click OK
This is where we will create the thumbnail images
you will click to display your projects in your website

Open your previous Photoshop project JPEG files
Move each project onto the Thumbnails template
Scale each image to the document canvas
Find the Photoshop logo on Google and place it
somewhere on the image (be creative)
Command S to Save as you go
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Open each Animate screenshot in Photoshop and
move them onto the Thumbnails template, scale, and
add the software logo
Find the Animate logo and place in same position
and make same size as you did the previous
Photoshop logo
Command S to Save as you go

Find images online that represent audio
(soundwaves, headphones, speakers, etc)
Place the images in the Thumbnails template
Need a different image for each of your audio
projects, and a screenshot for the Foley project
Add the software logo for audio projects (need
Audition and Garageband logos)
Command S to Save as you go

Use a Jazz image file and one of your story images
to create the video thumbnails and create those with
the Premiere logo just like you did for the previous
thumbnails
Command S to Save as you go

Move all of the Adobe and Garageband logos to the
top layers in the stack in Photoshop
Command S to Save
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Turn off all eyeball layers except the Premiere logo
and the the first Premiere project image

File > Save As
Name the file jazz thumb
Change the format to JPEG
Save in Documents > Dreamweaver > images

Change the JPEG Options to 5 Medium
Click OK

Open inside of Photoshop, the profile.png file that is
located in Documents > Dreamweaver > images

Repeat this process of turning on and off eyeball
layers and saving as JPEG files with the project
name and thumb (short for thumbnail) as the title.
All of these will be saved to the images folder
Take a photo of yourself or select a photo of yourself
that is school appropriate, and place it on top of the
profile circle image in Photoshop, and scale your
photo so that is it larger than the circle

With your photo layer still highlighted, hold
Command and click on the small thumbnail image of
the profile circle in the Layers window
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The dancing ants circle from the profile layer will
show around your photo

Click the Layer Mask button at the bottom of the
Layers window to mask your photo into the profile
circle

File > Save As
Name as profile copy
Change format to PNG
Save in Documents > Dreamweaver > images

Quit Photoshop
Open Dreamweaver
Open the portfolio website previously created
In the Files window, Click the dropdown arrow
beside images and you will see all your files that
were moved over and saved
DO NOT MOVE OR DELETE ANY FILES
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In the Code view locate the <title> within the <head>
of the code
Change the text from Light Theme to your first and
last name’s Portfolio

In the Code view locate the word GRID in the <h4>
header
Change it to PORTFOLIO (in all caps)
Notice the word GRID changes to PORTFOLIO in
the Design view above as well

In the Code view locate the <h3> header tag with
the name John Doe
Change the name to your first and last name
Notice the name changes to your name in the
Design view above as well

Click the double boxes with an arrow to Save All
Make sure to click on that every time you make a
change to the website
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In the Code view locate the profile.png image just
below where you just typed your name
When you click on it in the code or hover over it in
code with your mouse, it will show the image

In the Properties panel below the Code view you will
also see the profile image located in the Src box

In the Properties panel, locate the Src box, click and
hold on the round target symbol at the box located to
the left of the folder icon
Click, hold, and drag an arrow to the Files panel and
point the arrow on top of the file you created with
your photo called profile copy.png

In the Code view the img src updates to the profile
copy.png and in the Design view your photo updates
in the circle

To preview what you have in a web browser as you
go along, click on the bottom right corner of the Code
view on the box/mobile device box called Realtime
Preview

Choose Google Chrome from the Preview in
Browser window

Click the double boxes to Save All, and remember
to do this each time
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In Chrome you see the changes you have made
thus far with the coding and how they reflect in your
website portfolio

In the Code view locate the two paragraphs <p> of
lorem ipsum (fake text). Replace the text in
paragraph one with information about you and
replace the text in paragraph two with information
about what you have learned in the class this year.

Any time you want to see your progress in the
browser, click the Preview and check it out
Close the tab in the Chrome browser and return to
Dreamweaver
Make sure you do not type so much text that it goes
beyond the boundary of the blue box in the Design
view. Keep your information for both paragraphs
within the blue header box (and do not just copy the
text that is in this example, use your own words)

In the Code view locate the Stats Gallery Section
and the first <div class=”thumbnail”> and the img src
bkg_06.jpg file

Click on the img file in the code and it will show in
the Properties panel just like when we looked at the
profile image previously

In the Properties panel locate the Src box and click,
hold, drag from the target icon to the Files panel and
point the arrow to your first Photoshop project thumb
(ex. Sandwich thumb)

In the Code view you will see the bkg_06.jpg file
change to your sandwich thumb.jpg and you will see
the image appear in the thumbnail box in Design
view
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In Code view notice the <a href=”#”> tag that
appears to the left of the <img src> tag in the line of
code for the sandwich thumb.jpg image. This refers
to what this item is linked to

In Code view make sure the <img src> tag with the
sandwich thumb.jpg is still highlighted and you will
still see it in the Properties panel below
Locate the Link box in the Properties panel
Click hold, drag, the target button, located to the
right of the Link box, and drag an arrow to your
sandwich project (pettywsandwich.mp4) video in the
Files panel.

The thumbnail image is now a clickable link to your project and reflected in the <a href=”#”> tag of the code,
replacing the # with your project file
Save All and Preview in the browser to test

In Code view locate Heading 4 <h4> tag and the
word TITLE

Change TITLE to the name of the software used to
create the project followed by a dash and the name
of the project (ex PHOTOSHOP  SANDWICH)

Notice the name changes in the Design view above
as well

In Code view locate the paragraph <p> tag on the
next line that list HTML, CSS, JS, WordPress

Change to the topic area that this project was
created for (ex Graphics, Animation, Audio, Video)

Notice the name changes in the Design view above,
and you will continue to be able to see all changes
you make in the Code view show in the Design view
when the Split view option is chosen
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In Code view locate the paragraph <p> tag on the
next line that the text column with Lorem ipsum.
For each of these on each box you will go back to
your Digital Media powerpoints and include
information about that section of material you learned
in the semester
For example, the sandwich project was in Graphics,
and the text for the paragraph column could be
sentences that list the elements and principles of
design, or a sentence that list the common graphic
file formats.
ALL INFORMATION MUST BE IN COMPLETE
SENTENCES (NO BULLET POINT LISTS)

In Code view locate the paragraph <p> tag on the
next line that the text column with Lorem ipsum.

Change the text from lorem ipsum to some important
information you found in the powerpoint and type in
complete sentences. Pay attention to spelling as
that will be graded as well.

Must have different information for each box
that relates to the field of study based on looking
up information from the previously studied
powerpoints during the year. So graphic
information for graphics, animation information
for animation projects, etc.
DO NOT PUT MORE TEXT IN A TEXT COLUMN
THAN THE CURRENT SIZE BOX, TO MAINTAIN
UNITY. Meaning the BLUE line at the bottom of
each box should align with the one beside it in
the next box over. If it does not the add or delete
text so it fits appropriately.
In Code view move to line 34 of the code
You will repeat each of the process that you used for
the first <div class=”thumbnail”> for:
img src, a href, h4, p=tag, and p=text column tags
for all of the other 15 (or more if adding extra credit)
thumbnails.
As you edit code, remember not to delete any of
the </> tag symbols or information along the way

When previewed in the browser your website
portfolio should be looking something like this (but
not in this order)
Remember to Save All before you Preview
Remember to click EACH thumbnail in the browser
preview to make sure all your links take you to view
your project
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In Code view locate the Footer Section near the end
of all of the code

In Code view highlight the entire <footer></footer>
section of text and hit Delete on the keyboard

*(the line number for the code will vary based on if
you added more rows to show your extra credit work)

This will remove the entire Email me section at the
bottom of your website
In Code view locate the Copyrights Section

That finishes all the editing to the HTML code, now
you will style the website using the CSS
In the upper left of the screen, Click on the word
simpleGridTemplate.css to change from HTML
source code to the CSS

Change the year to the current year and change
GRID to Middle Creek High School

Similar to <tags> for HTML, key elements of the
CSS are the curly brackets and the semicolon

There will be certain parts of the CSS that you will
be required to edit, but if you are understanding the
CSS, then feel free to change any of the other items
that you understand (BUT ONLY BRANCH OUT ON
YOUR OWN IF YOU UNDERSTAND THE CODE)

In Code view locate the .intro { code around line
166 and hover your mouse over the hexadecimal
code for the background color. Dreamweaver will
show the color of any hexadecimal code value when
you hover or click on it
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This is the Blue background color that appears near
the top that contains your photo and information
about you and what you learned.

In Code view right click on the hexadecimal number
for the backgroundcolor and choose Quick Edit from
the menu that appears

A color picker window opens
Notice the same hexadecimal code number is
located in the bottom of this window

Use the sliders on the right and click the circle within
the color box on the left to choose the color of your
choice.
Notice the hexadecimal number changes with your
new color choice. You will use this number again

You will see the change in your Design view as well
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In Code view highlight and Command C copy your
new hexadecimal color code

In Code view locate .thumbnail { code around line
62 and the boarderbottom hexadecimal color around
line 73

Right click on the hexadecimal code and select
Quick Edit from the menu
When the color picker window opens, Highlight the
hexadecimal code at the bottom left and Command V
to paste in your new color code that you previously
copied and hit Return on the keyboard

In Design view you will see that the Blue line at the
bottom of all your thumbnail boxes has now changed
to your new color and now matches the top box that
contains your photo.

In Code view locate the .gallery .thumbnail h4 {
code around line 75

Change the color to your hexadecimal color
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In Design view your heading text will not be the
same color as your box that contains your photo and
your bottom border line under each thumbnail box

IF you understand the CSS and want to make other
changes like the background color for the top box or
the bottom box of your site you can do so as long as
they match for unity.
Otherwise you are done editing the HTML and CSS
and you are ready to Save All, Preview, and check all
your links to make sure all works correctly.

You site should look similar to this with the
differences being your photo, color scheme, and
layout of your projects

Open Finder window and go to
Documents > Dreamweaver

After checking to make sure everything works,
Quit Dreamweaver

Right click on the Dreamweaver folder and
compress to make a .zip file

Click the .zip file one time, hesitate a second, then
click a second time on the .zip Dreamweaver file
(NOT THE UNZIPPED FOLDER, DO NOT RENAME
OR MOVE THE ORIGINAL DREAMWEAVER
FOLDER)
Rename the .zip file:
last name+first initial+Dreamweaver.zip
Hit Return on keyboard to snap the new name in
place

The file will need to be collected by your instructor
as it will be too large to send over the website
dropbox.
Notify your instructor when you have your .zip file
ready to be turned in

